当前位置:
  1. 城市财经
  2. 股票学习
  3. 建仓
  4. 正文

飞狐准备建仓指标公式

飞狐准备建仓指标公式DRAWGBK(DATE》900101,COLORRGB(0,150,130),COLORRGB(0,0,0),1);

input:N(26,2,100);

{多空}

RSVp:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100-50;

Kv:=SMA(RSVp,3,1);

Dv:=SMA(Kv,3,1);

Jv:=3*Kv-2*Dv;

zdzk1:=EMA(Jv,6);

zdzk2:=REF(zdzk1,1);

做多:IF(zdzk1》=zdzk2,zdzk1+2,zdzk2),PRECISION2,COLORRED;

做空:IF(zdzk2-zdzk1,zdzk2,zdzk1),PRECISION2,COLORGREEn;

xw1:=IF(O《=REF(O,1),0,MAX((H-O),(O-REF(O,1))));//------------

xw2:=IF(O》=REF(O,1),0,MAX((O-L),(O-REF(O,1))));

xw3:=SUM(xw1,21);

xw4:=SUM(xw2,21);

xw5:=IF(xw3》xw4,(xw3-xw4)/xw3,IF(xw3=xw4,0,(xw3-xw4)/xw4));

{14天强弱}

RS:=SMA(MAX(C-REF(C,1),0),14,1)/SMA(ABS(C-REF(C,1)),14,1)*100;

ZD:=EMA(EMA(EMA(RS,7),3),3);

ZD1:=(ZD-REF(ZD,1))/REF(ZD,1)*15;

STICKLINE(ZD1》=0,0,ZD1*50,4,0),Color0000BE;

STICKLINE(ZD1《=0,0,ZD1*50,4,0),COLORCYAN;

y1:=AMOUNT/V/100;//--------------

y2:=(3*H+L+O+2*C)/7;

y3:=100*(WINNER(1.1*C)-WINNER(0.9*C));

y4:=SUM(AMOUNT,13)/y1/100;

y5:=DMA(y2,V/y4);

y6:=(C-y5)/y5*100;

y7:=(y3《10)AND(y6《=-10);

y8:=SMA(MAX(C-REF(C,1.5),0),6,1)/SMA(ABS(C-REF(C,1.5)),6,1)*100;

重亏:STICKLINE(y6《=-10andZD1《0,ZD1*55,ZD1*45,6,0),ColorFF89B2;

全亏:STICKLINE(y6《=-16andZD1《0,ZD1*60,ZD1*55,6,1),COLORBLUE;

超跌:STICKLINE(y7andZD1《0,ZD1*65,ZD1*60,6,0),ColorFFFFFF;

Jct:=100*(c-cost(10))/cost(10);//-----------

PARTLINE(C,if(Jct《0,Jct,0)*3),COLORWHITE;

{备战区1}

ZDD1:=(HHV(H,21)-C)/(HHV(H,21)-LLV(L,21))*100-10;

ZDD2:=(C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;

ZDD3:=SMA(ZDD2,13,8);

ZDD4:=CEILING(SMA(ZDD3,13,8));

ZDD5:=SMA(ZDD1,21,8);

Xh1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;

Xh2:=ZDD4-ZDD5《-65andXh1《12;

备战区:DRAWICON(Xh2,0,12),Color006EFF;

STICKLINE(Xh2,0,ZD1*20,4,0),Color006EFF;

{备战区2}

Xx1:=MA(LOW,2)*0.96;

Xx2:=MA(LOW,26)*0.85;

Xx3:=REF(Xx1,1)《Xx2ANDREF(Xx1,1)《Xx1ANDREF(Xx1,1)《REF(Xx1,2);{30}

STICKLINE(Xx3,0,ZD1*16,4,0),Color006EFF;

DRAWICON(Xx3,0,12);

{备战区3}

C0:=REF(C,2)*0.865;

C1:=REF(C,13)*0.772;

DSY:=100*vol/CApitAl;

STICKLINE((C-MIN(C0,C1))/C《0.1ANDSUM(DSY,5)/5《1.8,0,ZD1*25,4,0),Color006EFF;

DRAWICON((C-MIN(C0,C1))/C《0.1ANDSUM(DSY,5)/5《1.8,0,12);

{备战区4}

Ww1:=sum(ma(c,10),9)/10.110;

Ww2:=cross(c,Ww1);

STICKLINE(Ww2,0,ZD1*26,4,0),Color006EFF;{40}

DRAWICON(Ww2,0,12);

{买1}

Vw1:=DMA(EMA(C,12),SUM(V,5)/3/CAPITAL);

Vw2:=REF(H,10)/C》1.35;

Vw3:=(COST(20)-C)/C》0.15;

Vw4:=H》L*1.051;

Vw5:=Vw4ANDCOUNT(Vw4,5)》1;

Vw6:=(((C-Vw1)/Vw1*100《-30)orVw2)andVw3andVw5;

STICKLINE(Vw6,0,ZD1*40,4,0),Color0000FF;{48}

DRAWICON(Vw6,0,6);

{买2}

XL1:=MA(LOW,2)*0.96;

XL2:=MA(LOW,26)*0.85;

XL3:=REF(XL1,1)《XL2ANDREF(XL1,1)《XL1ANDREF(XL1,1)《REF(XL1,2);

STICKLINE(XL3,0,15,4,0),ColorF8B7F0;

DRAWTEXT(XL3,15,‘←买’),ColorF8B7F0;

{井喷}

jjp1:=REF(INDEXC,1);

jjp2:=FILTER((INDEXC-jjp1)/jjp1》0.03andzdzk1》=zdzk2,7);

STICKLINE(jjp2,0,-15,4,0),ColorFF00FF;

DRAWTEXT(jjp2,-15,‘←买’),ColorFF00FF;

//数据源

x1:=EMA(HHV(H,500),21);

x2:=EMA(HHV(H,250),21);

x3:=EMA(HHV(H,90),21);

x4:=EMA(LLV(L,500),21);

x5:=EMA(LLV(L,250),21);

x6:=EMA(LLV(L,90),21);

x7:=EMA((x1*0.558+x2*0.558+x3*0.558+x4*0.96+x5*0.96+x6*0.96)/6,21);

x8:=EMA((x1*0.55+x2*0.55+x3*0.65+x4*1.25+x5*1.23+x6*1.2)/6,21);

x9:=EMA((x1*0.68+x2*0.68+x3*0.68+x4*1.3+x5*1.3+x6*1.3)/6,21);

VARA:=EMA((x7*3+x8*2+x9)/6*1.738,21);//数据源

VARB:=REF(LOW,1);//昨天最低价

VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;//低价强弱

VARD:=EMA(IF(C*1.35《=VARA,VARC*10,VARC/10),3);

//C*1.35小于等于数据源取低价强弱线*10的3日均线,否则取低价强弱线/10的3日均线

VARE:=LLV(L,30);//取30日最低价

VARF:=HHV(VARD,30);//取VARD均线30日的最高值

VAR10:=IF(MA(C,58),1,0);//取58天均线的收盘价

VAR11:=EMA(IF(LOW《=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;//取值

MID:=REF(H+L,1)/2;//取作天的中价

CR:=SUM(MAX(0,H-MID),N)/SUM(MAX(0,MID-L),N)*100;//取MID26天的CR值

出击:IF(CR《60ANDVAR11》10,35{6000/CR},0),COLORGREEN;

攻击:IF(VAR11》20,{VAR11*3}30,0),COLORYELLOW;

{加仓}

xc1:=(MA(C,80)-MA(C,13)/3);

xc2:=MA((C-xc1)/xc1,1);

xc3:=ema(xc2,12)*0.7;

xc4:=ema(xc2,3);

xc5:=if(llv(xc4-xc3,12)》0,0,-10);

xc6:=EMA(C,12)-EMA(C,26);

xc7:=EMA(xc6,9);

xc8:=2*(xc6-xc7);

加仓:if(xc5《0andcross(xc8,0),50,0),LINETHICK1,colorblue;

DRAWICON(加仓》0,30,4);

DRAWTEXT(加仓,35,‘←加仓’),colorblue;

相关阅读

《飞狐准备建仓指标公式》由网友“煎熬”推荐。

转载请注明:http://www.citytt.com/study/1210134R12020.html