当前位置:
  1. 城市财经
  2. 股票学习
  3. 背离
  4. 正文

飞狐四合一背离指标公式

飞狐四合一背离指标公式DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA),COLORSTICK,LINETHICK2;

TRTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);

HD:=HIGH-REF(HIGH,1);

LD:=REF(LOW,1)-LOW;

PDM:=SUM(IF(HD》0ANDHD》LD,HD,0),14);

MDM:=SUM(IF(LD》0ANDLD》HD,LD,0),14);

PDI:=PDM*100/TRTR;

MDI:=MDM*100/TRTR;

A1:=BARSLAST(ref(cross(“macd.diff”(12,26,9),“macd.dea”(12,26,9)),1));

B1:=ref(c,A1+1)》candref(“macd.diff”(12,26,9),A1+1)《“macd.diff”(12,26,9)andcross(“macd.diff”(12,26,9),“macd.dea”(12,26,9));

A2:=BARSLAST(ref(cross(“kdj.k”(9,3,3),“kdj.d”(9,3,3)),1));

B2:=ref(c,A2+1)》candref(“kdj.k”(9,3,3),A2+1)《“kdj.k”(9,3,3)andcross(“kdj.k”(9,3,3),“kdj.d”(9,3,3));

A3:=BARSLAST(ref(cross(“RSI.RSI1”(6,12,24),“RSI.RSI2”(6,12,24)),1));

B3:=ref(c,A3+1)》candref(“RSI.RSI1”(6,12,24),A3+1)《“RSI.RSI1”(6,12,24)andcross(“RSI.RSI1”(6,12,24),“RSI.RSI2”(6,12,24));

C1:=BARSLAST(ref(cross(“macd.dea”(12,26,9),“macd.diff”(12,26,9)),1));

D1:=ref(c,C1+1)《candref(“macd.diff”(12,26,9),C1+1)》“macd.diff”(12,26,9)andcross(“macd.dea”(12,26,9),“macd.diff”(12,26,9));

C2:=BARSLAST(ref(cross(“kdj.d”(9,3,3),“kdj.k”(9,3,3)),1));

D2:=ref(c,C2+1)《candref(“kdj.k”(9,3,3),C2+1)》“kdj.k”(9,3,3)andcross(“kdj.d”(9,3,3),“kdj.k”(9,3,3));

C3:=BARSLAST(ref(cross(“RSI.RSI2”(6,12,24),“RSI.RSI1”(6,12,24)),1));

D3:=ref(c,C3+1)《candref(“RSI.RSI1”(6,12,24),C3+1)》“RSI.RSI1”(6,12,24)andcross(“RSI.RSI2”(6,12,24),“RSI.RSI1”(6,12,24));

C4:=BARSLAST(ref(cross(mdi,pdi),1));

D4:=ref(c,C+1)《candref(mdi,C4+1)》mdiandcross(mdi,pdi);

A4:=BARSLAST(ref(cross(PDI,MDI),1));

B4:=ref(c,A4+1)》candref(pdi,A4+1)《pdiandcross(pdi,mdi);

DMI底背:IF(B4》0,-0.1,0),COLOR0099FF,POINTDOT;

MACD底背:if(B1》0,-0.1,0),colorred,pointdot;

KDJ底背:if(B2》0,-0.1,0),colorff00ff,pointdot;

RSI底背:if(B3》0,-0.1,0),coloryellow,pointdot;

DMI顶背:IF(D4》0,0.1,0),COLORBLUE,POINTDOT;

MACD顶背:if(D1》0,0.1,0),color00ff00,pointdot;

KDJ顶背:if(D2》0,0.1,0),colorffcc66,pointdot;

RSI顶背:if(D3》0,0.1,0),colorwhote,pointdot;

STICKLINE(B1》0,-0.1,0,6,0),colorred;

STICKLINE(B2》0,-0.1,0,6,0),colorff00ff;

STICKLINE(B3》0,-0.1,0,6,0),coloryellow;

STICKLINE(d1》0,0.1,0,6,0),color00ff00;

STICKLINE(d2》0,0.1,0,6,0),colorffcc66;

STICKLINE(d3》0,0.1,0,6,0),colorwhite;

STICKLINE(B4》0,-0.1,0,6,0),color0099ff;

STICKLINE(D4》0,0.1,0,6,0),colorblue

相关阅读

《飞狐四合一背离指标公式》由网友“腻爱”推荐。

转载请注明:http://www.citytt.com/study/1210134Z32020.html