当前位置:
  1. 城市财经
  2. 股票学习
  3. 正文

飞狐阴阳河生死指标公式

飞狐阴阳河生死指标公式DRAWGBK(CLOSE》0,COLORRGB(1,0,0),COLORRGB(1,0,0),2);

STICKLINE(MA(CLOSE,60)》MA(CLOSE,5),MA(CLOSE,60),MA(CLOSE,5),0,0),COLOR888877,POINTDOT;

STICKLINE(MA(CLOSE,60)《MA(CLOSE,5),MA(CLOSE,60),MA(CLOSE,5),0,0),COLOR33AAFF,POINTDOT;

STICKLINE(MA(CLOSE,60)=MA(CLOSE,5),MA(CLOSE,60),MA(CLOSE,5),0,0),COLORCC11CC,POINTDOT;

hh:=SYSPARAM(4);ll:=SYSPARAM(5);

x:=ll-(hh-ll+MINDIFF)/5;

y:=HHV(VOL,SYSPARAM(3)-SYSPARAM(2)+1);

yvb:=y[SYSPARAM(3)]/(ll-x+MINDIFF);

z:=VOL/yvb+x;

a:=SYSPARAM(4)-SYSPARAM(5);//画面高低差幅

ab:=SYSPARAM(4)+a/3;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,9,0),colorAA;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,8,0),color11BB;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,7,0),color22CC;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,6,0),color33DD;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,5,0),color44EE;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,4,0),color55FF;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,2.2,0),color66FF;

STICKLINE(CLOSE》REF(CLOSE,1),x,z,1.5,0),color77FF;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,9,0),colorAA00;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,8,0),colorBB11;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,7,0),colorCC22;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,6,0),colorDD33;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,5,0),colorEE44;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,4,0),colorFF55;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,2.5,0),colorFF66;

STICKLINE(CLOSE《=REF(CLOSE,1),x,z,1.5,0),colorFF77;

五日:MA(z,5),COLORWHITE;

十日:MA(z,10)COLORGREEN;

DRAWICON(CROSS(五日,十日),十日,12),COLORred;

ab:MA(CLOSE,5),COLORGRAY;

aa:=MA(CLOSE,10),COLORGRAY;

a1:=a=HHV(ab,SYSPARAM(4));

a2:=BARSLAST(a1);

bb:=REF(ab,a2);

gg:=IF(HIGH》ab,ab,ab);

DRAWLINE(HIGH=SYSPARAM(4),HIGH,BARPOS=SYSPARAM(1),HHV(ab,10),1),COLORGRAY;

VAR01:=MA(CLOSE,60);

PARTLINE(VAR01》REF(VAR01,1),VAR01),colorcc,LINETHICK3;

PARTLINE(VAR01《REF(VAR01,1),VAR01),COLOR00cc00,LINETHICK3;

PARTLINE(ABS(VAR01-REF(VAR01,1))/VAR01*10000《8,VAR01),COLORBLUE,LINETHICK3;

PARTLINE(ABS(ab-REF(ab,1))/ab*10000《8,ab),COLORBLUE,LINETHICK3;

VAR02:=HHV(VAR01,0);

VAR03:=LLV(VAR01,0);

DRAWSL(VAR01=VAR02[DATACOUNT],VAR01,0,0,0),coloryellow,POINTDOT,LINETHICK1;

DRAWSL(VAR01=VAR03[DATACOUNT],VAR01,0,0,0),colorred,POINTDOT,LINETHICK1;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,0,0),COLOR00FF00;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,8,0),COLOR008800;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,7,0),COLOR009900;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,6,0),COLOR00AA00;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,5,0),COLOR00BB00;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,4,0),COLOR00CC00;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,3,0),COLOR00DD00;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,2,0),COLOR00EE00;

STICKLINE(OPEN》CLOSE,CLOSE,OPEN,1,0),COLOR00FF00;

STICKLINE(OPEN》CLOSE,HIGH,LOW,0.5,0),COLOR00FF00;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,8,0),color33;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,7,0),color55;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,6,0),color77;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,5,0),color99;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,4,0),colorBB;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,3,0),colorDD;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,2,0),colorFF;

STICKLINE((CLOSE》=OPEN),CLOSE,OPEN,1,0),colorFF;

STICKLINE((CLOSE》=OPEN),LOW,HIGH,0.5,0),colorFF;

DRAWICON(CROSS(ab,aa),LOW*0.998,12);

DRAWICON(CROSS(aa,ab),HIGH*1.005,11);

DRAWTEXT(CROSS(CLOSE,VAR01)andVAR01》=REF(VAR01,1),LOW*0.99,‘★’),COLORYELLOW;

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

MACD1:=CROSS(DIFF,DEA)ANDCOUNT(MACD》0,1)=1;

MACD2:=CROSS(Dea,Diff)ANDCOUNT(MACD《0,1)=1;

均线:=CROSS(MA(CLOSE,5),MA(CLOSE,10));

量线:=CROSS(MA(VOL,5),MA(VOL,10));

SCC:=MACD1AND均线AND量线;

SC2:=均线AND量线;

SC3:=均线ANDMACD1;

SC6:=MACD1AND量线;

SC7:=CLOSE》MA(CLOSE,120);

sc8:=(SCCORSC2ORSC3ORSC6)ANDSC7;

DRAWTEXT(sc8,LOW*0.99,‘★\n红\n三\n军’),COLORred;

DRAWICON(sc8,LOW*0.998,12);

TY:=CLOSE;

HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);

LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);

A:=REF(CLOSE,BARSLAST(HD));

B:=REF(CLOSE,BARSLAST(LD));

T1:=BARSLAST(HD)《BARSLAST(LD)ANDNOT(HD);

T2:=BARSLAST(HD)》BARSLAST(LD)ANDNOT(LD);

IF(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK1;

IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK1;

大盘上涨家数:=INDEXADV;

平盘家数P:=PINGPAN;

大盘下跌家数:=INDEXDEC;

DRAWTEXTEX(1,0,545,30,‘上涨:’+NUMTOSTR(大盘上涨家数,0)+‘家’),Colorred;

DRAWTEXTEX(1,0,645,30,‘平盘:’+NUMTOSTR(平盘家数P,0)+‘家’),Color00FFFF;

DRAWTEXTEX(1,0,725,30,‘下跌:’+NUMTOSTR(大盘下跌家数,0)+‘家’),Colorred;

DRAWTEXTEX(1,0,630,60,‘★天心箭★’),COLORGRAY;

AA1:=(STRFIND(STKNAME,‘ST’,0)=0);

K0:=IF(AA1,10,20);

A1:=((REF(CLOSE,1)/K0)+REF(CLOSE,1));

A2:=(0-((REF(CLOSE,1)/K0)-REF(CLOSE,1)));

SZ5:=((‘涨停价:’+NUMTOSTR(A1,2))+‘元’);

SZ6:=((‘跌停价:’+NUMTOSTR(A2,2))+‘元’);

DRAWTEXTEX(CLOSE,1,535,120,sz5),colorFF;

DRAWTEXTEX(CLOSE,1,600,120,sz6),colorFF00;

DRAWTEXTEX(ma(c,60)《ref(ma(c,60),1)andc《ma(c,60),0,545,90,‘★阴阳河下死︻$▅▆▇◤坚决空仓★’),COLORMAGENTA;

DRAWTEXTEX(ma(c,60)》=ref(ma(c,60),1)andc》=ma(c,60),0,545,90,‘★阴阳河上生︻$▅▆▇◤开始看多★’),COLORMAGENTA;

相关阅读

《飞狐阴阳河生死指标公式》由网友“旧梦”推荐。

转载请注明:http://www.citytt.com/study/1210134Z92020.html