当前位置:
  1. 城市财经
  2. 股票学习
  3. 正文

通达信KDJ相对能量指标公式

N:=9;M1:=3;M2:=3;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:SMA(RSV,M1,1),COLORWHITE,LINETHICK2;

D:SMA(K,M2,1),COLORYELLOW,LINETHICK2;

J:3*K-2*D,COLORMAGENTA,LINETHICK2;

OBV:=K;

P:=5;

A1:=REF(OBV,P)=HHV(OBV,2*P+1);

B1:=FILTER(A1,P);

C1:=BACKSET(B1,P+1);

D1:=FILTER(C1,P);{高点}

A2:=REF(OBV,P)=LLV(OBV,2*P+1);

B2:=FILTER(A2,P);

C2:=BACKSET(B2,P+1);

D2:=FILTER(C2,P);{低点}

上:REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW;

下:REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW;

向上:CROSS(OBV,上*1.01),NODRAW;

相对能量:(OBV-下)/(上-下)*100,COLORYELLOW,NODRAW;

R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);

S11:=R11>REF(R11,1);

{股旁网-股票公式网站 www.GupaNg.com}

DRAWLINE(D1,OBV,S11,OBV,1),COLOR0000FF;

T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);

U11:=T11>REF(T11,1);

DRAWLINE(D2,OBV,U11,OBV,1),COLORFFFF00;

STICKLINE(C>0,下,下,1,0),COLOR00FF00;

STICKLINE(C>0,上,上,1,0),COLORFF00FF;

DRAWTEXT(CROSS(OBV,上*1.01),上,'上'),COLORFFFFFF;

DRAWTEXT(CROSS(下*0.99,OBV),下,'下'),COLORFFFFFF;

{主升波段显示}

BBI:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;

EBBI:=(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4;

FF1:=EMA(C,3)>EMA(C,7) AND EMA(C,7)>EMA(C,21) AND EMA(C,21)>EMA(C,54);

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

主升浪:IF(BBI>EBBI AND FF1 AND DIFF>DEA,10,0),COLORYELLOW,POINTDOT;

STICKLINE(主升浪,10,0,1,1),COLORYELLOW;

DRAWICON(CROSS(K,D) AND CROSS(J,D),10,1);{1号图标显示红箭头};

DRAWICON(D1,OBV,27);

DRAWICON(D2,OBV,25);

{金叉共振}

VAR0004:="KDJ.K#WEEK"(9,3,3);

VAR0005:="KDJ.D#WEEK"(9,3,3);

VAR0006:="KDJ.K#MONTH"(9,3,3);

VAR0007:="KDJ.D#MONTH"(9,3,3);

周金叉:IF(CROSS(VAR0004,VAR0005),15,0)LINESTICK, COLORRED;

月金叉:IF(CROSS(VAR0006,VAR0007),20,0)LINESTICK,COLORYELLOW;

DRAWTEXT(周金叉,16,'周金叉'),COLORRED;

DRAWTEXT(月金叉,20,'月金叉'),COLORYELLOW;

{抄底加仓}

抄底:IF(REF(COUNT(K=5,1) AND COUNT(K<30,5)>=2 AND COUNT(J<0,3)>0 AND CROSS(J,0),60,50),COLOR00FFFF;

TJ00:=BARSLAST(REF(CROSS(K,D) AND REF(K,1)<35,1));

TJ11:=C5 AND K>REF(K,TJ00+1) AND CROSS(K,D);

加仓:IF(TJ11,35,0),COLORGREEN;

A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

DRAWICON(CROSS(K,D),K,1);

DRAWICON(CROSS(D,K),D,2);

通达信KDJ相对能量指标公式

相关阅读

《通达信KDJ相对能量指标公式》由网友“俞事”推荐。

转载请注明:http://www.citytt.com/study/12163229412020.html