当前位置:
  1. 城市财经
  2. 股票学习
  3. 正文

通达信箱体支撑+缺口主图指标公式

N:=8;

P:=0;

【箱顶】:PEAK(CLOSE,N,1)*0.98;

【箱底】:TROUGH(CLOSE,N,1)*1.02;

【箱高】:100*(【箱顶】-【箱底】)/【箱底】,NODRAW;

KOH:=L>REF(H,1);

KOL:=H

HIF:=L>REF(H,BARSLAST(KOH)+1);

NHIF:=L<=REF(H,BARSLAST(KOH)+1);

LIF:=H

NLIF:=H>=REF(L,BARSLAST(KOL)+1);

AA:=REF(H,N)=HHV(H,2*N+1);

AA1:=REF(L,N)=LLV(L,2*N+1);

QY:=BACKSET(AA,N+1);

QY1:=BACKSET(AA1,N+1);

CC:=FILTER(QY,N) AND H=HHV(H,N+1);

CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);

DDD:=BARSLAST(CC);

DD1:=BARSLAST(CC1);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

{股旁网-股票公式网站 www.GUpang.com}

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

GDCS1:=CONST(DINGBUTS);

DDCS1:=CONST(DDTS1);

GDCS13:=CONST(REF(HIGH,GDCS1-1));

DDCS13:=CONST(REF(L,DDCS1-1));

DINGBUTS1:=REF(DINGBUTS,DDD+1);

DDTS2:=REF(DDTS1,DD1+1);

GDCS2:=CONST(DINGBUTS1);

DDCS2:=CONST(DDTS2);

GDCS23:=CONST(REF(HIGH,DINGBUTS1-1));

DDCS23:=CONST(REF(L,DDTS2-1));

XG1:=BACKSET(ISLASTBAR,GDCS1);

XD1:=BACKSET(ISLASTBAR,DDCS1);

XG2:=BACKSET(ISLASTBAR,DINGBUTS1);

XD2:=BACKSET(ISLASTBAR,DDTS2);

XDD:=IF(DDCS13<=DDCS23,XD1,XD2);

BCG:=SUM(XG1,0);

BCD:=SUM(XDD,0);

上缺口:=P=0 AND HIF AND BARSLAST(KOH)

HG:=IF(上缺口{ AND DATE<1091201}{},REF(H,BARSLAST(KOH)+1),DRAWNULL);

STICKLINE(上缺口,HG,HG*1.001,10,0),COLOR888888;

下缺口:=P=0 AND LIF AND BARSLAST(KOL)

LG:=IF(下缺口{ AND DATE<1091201}{},REF(L,BARSLAST(KOL)+1),DRAWNULL);

STICKLINE(下缺口{ AND DATE<1091201}{},LG,LG*0.999,10,0),COLOR888888;

通达信箱体支撑+缺口主图指标公式

相关阅读

《通达信箱体支撑+缺口主图指标公式》由网友“张波”推荐。

转载请注明:http://www.citytt.com/study/12163231Y2020.html