当前位置:
  1. 城市财经
  2. 股票学习
  3. 正文

通达信百年经典主图指标公式

间隔:=3;角度:=4;

M1:=IF((CLOSE > 100),1,0.01);

M2:=(1 / 间隔);

PYEAR:=(角度 * 0.25);

BB:=LLV(YEAR,0);

PMONTH:=SUM(MONTH,0);

CC:=LLV(PMONTH,0);

PDAY:=SUM(DAY,0);

P1990:=LLV(PDAY,0);

T1990:=((((YEAR - 1990) * 365.24219) + ((MONTH - 1) * 30.43685)) + DAY);

A:=((((BB - 1990) * 365.24219) + ((CC - 1) * 30.436)) + P1990);

V1:=CEILING((T1990 - A));

V2:=((V1 * M1) * PYEAR);

V3:=(V2 - ((CEILING(((V2 - CLOSE) / (365.24219 * M1))) * 365.24219) * M1));

V333:=(V2 - ((FLOOR(((V2 - CLOSE) / (365.24219 * M1))) * 365.24219) * M1));

V444:=(V2 - (((CEILING(((V2 - CLOSE) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

V4:=(V2 - (((FLOOR(((V2 - CLOSE) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

{PLOYLINE((ABS((V444 - REF(V444,1))) < (10 * M1)),V444),,COLORFF;

PLOYLINE((ABS((V4 - REF(V4,1))) < (10 * M1)),V4),,COLORFF;}

V5:=REVERSE(V2);

V6:=(V5 + ((CEILING(((CLOSE - V5) / (365.24219 * M1))) * 365.24219) * M1));

V555:=(V5 + ((FLOOR(((CLOSE - V5) / (365.24219 * M1))) * 365.24219) * M1));

V666:=(V5 + (((CEILING(((CLOSE - V5) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

V22:=(V5 + (((FLOOR(((CLOSE - V5) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

{PLOYLINE((ABS((V666 - REF(V666,1))) < (10 * M1)),V666),,COLORFF00;

PLOYLINE((ABS((V22 - REF(V22,1))) < (10 * M1)),V22),,COLORFF00;}

V33:=(V2 - ((CEILING(((V2 - MA(CLOSE,30)) / (365.24219 * M1))) * 365.24219) * M1));

V3333:=(V2 - ((FLOOR(((V2 - MA(CLOSE,30)) / (365.24219 * M1))) * 365.24219) * M1));

V4444:=(V2 - (((CEILING(((V2 - MA(CLOSE,30)) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

V44:=(V2 - (((FLOOR(((V2 - MA(CLOSE,30)) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

{PLOYLINE((ABS((V4444 - REF(V4444,1))) < (10 * M1)),V4444),,COLORFF0000;

PLOYLINE((ABS((V44 - REF(V44,1))) < (10 * M1)),V44),,COLORFF0000;}

V55:=REVERSE(V2);

V66:=(V55 + ((CEILING(((MA(CLOSE,30) - V55) / (365.24219 * M1))) * 365.24219) * M1));

V5555:=(V55 + ((FLOOR(((MA(CLOSE,30) - V55) / (365.24219 * M1))) * 365.24219) * M1));

V6666:=(V55 + (((CEILING(((MA(CLOSE,30) - V55) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

VAR1:=(V55 + (((FLOOR(((MA(CLOSE,30) - V55) / ((365.24219 * M1) * M2))) * 365.24219) * M1) * M2));

{PLOYLINE((ABS((V6666 - REF(V6666,1))) < (10 * M1)),V6666),,COLORFF00DD;

PLOYLINE((ABS((VAR1 - REF(VAR1,1))) < (10 * M1)),VAR1),,COLORFF00DD;}

M5:=MA(C,5);

E5:=EMA(C,5);

M10:=MA(C,10);

E10:=EMA(C,10);

M20:=MA(C,20);

E20:=EMA(C,20);

M50:=MA(C,50);

E50:=EMA(C,50);

M60:=MA(C,60);

E60:=EMA(C,60);

M120:=MA(C,120);

E120:=EMA(C,120);

M250:=MA(C,250);

E250:=EMA(C,250);

STICKLINE((E250>=M250),E250,M250,2,0),COLORRED;

STICKLINE((E120>=M120),E120,M120,6,0),COLORWHITE;

STICKLINE((E60>=M60),E60,M60,6,0),COLORBLUE;

STICKLINE((E50>=M50),E50,M50,6,0),COLORYELLOW;

STICKLINE((E20>=M20),E20,M20,6,0),COLORMAGENTA;

STICKLINE((E20>=M20),E20,M20,6,0),COLORMAGENTA;

STICKLINE((E20<=M20),M20,E20,6,0),COLORGREEN;

STICKLINE((E10>=M10),M10,E10,6,0),COLOR88FFDD;

STICKLINE((E10<=M10),M10,E10,6,0),COLORFFCD02;STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.1,0),COLOR0000FF;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.1,0),COLOR0000FF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0),LINETHICK2,COLOR5050FF;{红柱}

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.5,0),COLOR5050FF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.3,0),COLOR5F5FFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR5F5FFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.75,0),COLOR6C6CFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.5,0),COLOR6C6CFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR7E7EFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),COLOR7E7EFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.65,0),COLOR9D9DFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR9D9DFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.1,0),COLORAFAFFF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),COLORAFAFFF;

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(C=O,C,O,8,0),COLOR009900;STICKLINE(CLOSE=OPEN,OPEN,LOW,0.1,0),COLORFF8A85;STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

STICKLINE(CLOSE

{股旁网-股票公式网站 www.GUpang.com}

AS:=BACKSET(ISLASTBAR,HHVBARS(HIGH,45)+1);

B:=AS>REF(AS,1);

D:=BACKSET(ISLASTBAR,LLVBARS(LOW,45)+1);

E:=D>REF(D,1);

HH:=REF(HIGH,BARSLAST(B));

LL:=REF(LOW,BARSLAST(E));

高点:HH,LINETHICK2;

低点:LL,LINETHICK2;

C点:PLOYLINE(1,HH*0.8709),COLORFF0000,LINETHICK2;

{B点:PLOYLINE(1,HH*0.75),LINETHICK2,COLORFFFFFF;

PLOYLINE(1,HH*0.7252),COLORFFFFFF;

PLOYLINE(1,HH*0.667),CROSSDOT,COLORFFDDEE;

PLOYLINE(1,HH*0.625),COLORFFDDEE;}

{M点:PLOYLINE(1,HH*0.5),LINETHICK2,COLORFFFFEE;}

DRAWTEXT(ISLASTBAR,HH*0.8709,'有名底'),COLORFFFF11;

{DRAWTEXT(ISLASTBAR,HH*0.7252,'无名底'),COLORFFFF22;

DRAWTEXT(ISLASTBAR,HH*0.625,'超跌底'),COLORFFFF33;

DRAWTEXT(ISLASTBAR,HH*0.5,'狂跌底'),COLORFFFF44; };

通达信百年经典主图指标公式

相关阅读

《通达信百年经典主图指标公式》由网友“芯話”推荐。

转载请注明:http://www.citytt.com/study/12163232212020.html