当前位置:
  1. 城市财经
  2. 股票学习
  3. 正文

通达信神秘乾坤主图指标公式

M1:=5;

M2:=10;

M3:=20;

M4:=60;

M5:=120;

M6:=250;

MA1:MA(CLOSE,M1),COLOR0000FF;

MA2:MA(CLOSE,M2);

MA3:MA(CLOSE,M3);

MA4:MA(CLOSE,M4);

MA5:MA(CLOSE,M5);

MA6:MA(CLOSE,M6);

A:=BARSCOUNT(CLOSE);

AH:=HHV(HIGH,200);

AL:=LLV(LOW,200);

B0:=(AH-AL)/40;

B1:=HIGH+B0;

B2:=LOW-B0;

DRAWTEXT((A+0)/34=FLOOR((A+0)/34),

B2-2.2*B0*1.1,'←窗,变盘'),COLORRED;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;

DRAWICON(CROSS(RSI,11) ,L*0.99,3);

VAR28:=SMA(MAX(CLOSE-LC,0),5.5,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),LOW,'买'),COLORFF00FF;

VARA:=((AMOUNT)/(VOL))/(100);

VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);

VARC:=((SUM(AMOUNT,7))/(VARA))/(100);

VARD:=DMA(VARB,(VOL)/(VARC));

VARE:=((CLOSE-VARD)/(VARD))*(100);

VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);

VARJ:=MA(VARE,20)+STD(VARE,20);

{股旁网-股票公式网站 www.GUpang.com}

BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);

AA:=SMA(VARF,3,1);

SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (AA>79);

V7:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);

STICKLINE(V7>=1,O,C,1,0),COLORYELLOW;

LC1:=REF(CLOSE,1);

RSI1:=((SMA(MAX((CLOSE - LC1),0),3,1) / SMA(ABS((CLOSE - LC1)),3,1)) * 100);

FF:=EMA(CLOSE,3); MA15:=EMA(CLOSE,21);

DRAWTEXT(CROSS(FF,MA15),(LOW * 0.85),'←底背离'),COLORYELLOW;

AA1:=(HHV(HIGH,20) - (2 * ATR));

BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));

SSS:=CROSS(MIN(MA(CLOSE,13),AA1),CLOSE);

BBB:=BARSLAST(BB); SSSB:=BARSLAST(SSS);

B11:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));

B1B:=BARSLAST(B11);

B21:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));

B2B:=BARSLAST(B21); B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));

VAR2S:=(2*CLOSE+HIGH+LOW)/4;

VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);

VAR4S:=LLV(LOW,5);

VAR5S:=HHV(HIGH,4);

散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;

庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;

DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←吸'),COLORRED;

MA20:=MA(C,20);

MA90:=MA(C,90);

Y1:=BARSLAST(CROSS(MA5,MA20)) AND MA5>MA20;

Y2:=Y1 AND BARSLAST(CROSS(MA5,MA90));

Y3:=Y2 AND CROSS(MA20,MA90);

STICKLINE(Y3,O,C,3,0),COLORYELLOW;

DRAWTEXT(Y3,L-0.40,'←黑马'),COLORWHITE;

F0:=BARSLAST(CROSS(MA(C,5),MA(C,90)));

F1:=F0 AND BARSLAST(CROSS(MA(C,20),MA(C,90)));

F2:=F1 AND CROSS(MA(C,5),MA(C,20)) AND MA(C,20)>MA(C,90);

DRAWICON(F2,L-0.10,1);

DRAWTEXT(F2,L-0.40,'←黑马'),COLORFF00FF;

M:=OPEN;

M11:=MA(C,1);

M22:=REF(M11,1);

M33:=REF(M22,1);

保护价:(M22+M33+M)/3,COLORWHITE,LINETHICK0;

{DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),LINETHICK2,COLORRED;

DRAWTEXT(CROSS(X,Y),(HIGH * 1.02),'◆'),LINETHICK2,COLOR00FF00;

DRAWTEXT(DB,(HIGH * 1.02),'●'),LINETHICK2,COLOR00FF00;}

VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);

VAR3:=LLV(LOW,55);

VAR4:=HHV(HIGH,34);

VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);

VAR6:=((AK + VAR5) / 2); VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);

VAR8:=EMA(VAR6,5);

BBA:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);

AB:=CROSS(AK1,AK);

BB1:=(CROSS(AK1,BBA) AND (BBA < 30));

CD:=(BBA * 0.6); DRAWTEXT((CD = 0.6),(LOW * 0.99),'□'),LINETHICK2,COLOR33CC99;

DRAWTEXT((AB = 1),(LOW * 0.99),'□'),LINETHICK2,COLORWHITE;

C1:=(CLOSE+LOW+HIGH)/3;

C2:=EMA(C1,6);

C3:=EMA(C2,5);

C4:=CROSS(C2,C3);

DRAWTEXT(C4,LOW/1.01,'★'),,COLORRED;

C5:=CROSS(C3,C2);

DRAWTEXT(C5,HIGH*1.03,'★'),,COLORBLUE;

{IF(MA1>REF(MA1,1),MA1,DRAWNULL),COLORRED,LINETHICK2;

IF(MA1>REF(均衡,1) AND 中轨>REF(C,1),11);

DRAWTEXT(VAR55,L*0.98,'←追'),COLORYELLOW;};

通达信神秘乾坤主图指标公式

相关阅读

《通达信神秘乾坤主图指标公式》由网友“姌冰”推荐。

转载请注明:http://www.citytt.com/study/12163235L2020.html